演示:PPPOE服务端、拨号路由器、拨号计算机的装备51CTO博客 - AG环亚娱乐

演示:PPPOE服务端、拨号路由器、拨号计算机的装备51CTO博客

2019-01-03 15:30:44 | 作者: 运诚 | 标签: 拨号,装备,路由器 | 浏览: 1195

演示:PPPOE效劳端、拨号路由器、拨号计算机的装备


对应演示录像:http://edu.51cto.com/lecturer/user_id-7648423.html


演示方针:完结如下演示方针。

nPPPOE效劳端的装备(DSL网络会聚路由器的装备)。

nPPPOE拨号计算机的装备。

nPPPOE拨号路由器的装备。

演示环境:如下图8.104所示。


演示布景:在如图8.104所示的演示环境,DLS_ISP是ADSL网络的会聚路由器,也是PPPOE拨号效劳端,环境中的计算机是一台集了PPPOE拨号功用的windows XP计算机,路由器R1是一台PPPOE拨号客户端,现在装备DSL_ISP具有PPPOE的拨号接纳与身份验证的功用,让计算机和路由器R1都能成功的通过PPPOE拨号去拜访Internet骨干,并成功取得DSL_ISP为它们颁布的IP地址。

演示进程:


第一步:装备DSL会聚路由器,使其它承受CPE设备(计算机和路由器R1)的PPPOE拨号恳求,并为它们分配IP地址。


DSL会聚路由器的装备:

DSL_ISP(config)#username adsl01 password ccna123 *树立第一个PPPOE拨号用户与暗码

DSL_ISP(config)#username adsl02 password ccna456 *树立第二个PPPOE拨号用户与暗码


DSL_ISP(config)#bba-group pppoe ccna * 树立一个叫做ccna的BBA组。

DSL_ISP(config-bba-group)#virtual-template 1 *将虚拟模板接口1相关到BBA组中。


留意:bba-group是一个虚拟拨号组,从前的IOS(12.2(13)T之前)中,PPPOE的拨号是被嵌入到VPDN中,可是后来思科将PPPOE从VPDN中移植出来,嵌入到bba组中;virtual-template是设备所运用的虚拟拜访接口,一个PPPOE的拨号衔接便是归于虚拟拜访的一种,该接口上存放着与虚拟拜访有关的三层和二层信息,一般,需求把这个virtual-template与bba-group相关起来,或许在思科的英文文档中叫“cloning(克隆)”该接口到bba组中。


DSL_ISP(config)#interface virtual-template 1 * 进入虚拟模板接口1

DSL_ISP(config-if)#ip unnumbered e1/1 * 装备该接口向E1/1借IP地址。

DSL_ISP(config-if)#encapsulation ppp * 为该接口封装PPP协议

DSL_ISP(config-if)#ppp authentication pap * 在该接口发动PAP认证。

DSL_ISP(config-if)#peer default ip address pool adsl *为PPPOE拨号客户端分配一个叫做“adsl”地址池中的IP地址。


DSL_ISP(config)#interface e1/0 * 进入E1/0接口(PPPOE的桥接端接口)。

DSL_ISP(config-if)#pppoe enable * 发动PPPOE协议。

DSL_ISP(config-if)#pppoe enable group ccna * 将“ccna”的BBA组与该接口相关。


DSL_ISP(config)#ip local pool adsl 202.202.2.3 202.202.2.254 *树立一个叫“adsl”要分配给PPPOE拨号客户端的IP地址池。


DSL_ISP(config)#interface e1/1 * 接入E1/1接口。

DSL_ISP(config-if)#ip address202.202.1.1 255.255.255.0 * 为该接口装备IP地址。

DSL_ISP(config-if)#no shutdown * 激活该接口。

DSL_ISP(config-if)#exit

第二步:装备windows XP的计算机发动PPPOE的长途拨号衔接,详细操作如所示:建一个如下图8.105所示的新建衔接导游;在下图8.106所示的界面中挑选衔接到Internet;挑选如下图8.107所示的手艺衔接;在下图8.108所示的界面中挑选要求用户名与暗码来衔接;在下图8.109所示的界面中输入PPPOE拨号所需求用户号与暗码,这儿的用户名与暗码实际上便是在DSL网络会聚路由器DSL_ISP上所树立的用户名与暗码;当一切装备完结时,终究会呈现如下图8.110所示的衔接界面,能够开端PPPOE的衔接。假如装备无误,应该能够通过PPPOE的拨号成功的衔接到DSL网络的会聚路由器DSL_ISP,并且能够看到如下图8.111所示的状况信息,指示正在运用PPPOE协议,并且在成功的得到了PPPOE效劳端为它分配的IP地址202.202.2.3;然后,能够ping 202.202.1.1(PPPOE的效劳端),如下图8.112所示,成功通讯。


第三步:上面装备的是一台支撑PPPOE拨号计算机的拨入,在该进程中,将演示PPPOE拨号客户端路由器的装备,完结的装备与阐明如下所示:


PPPOE的拨号客户端路由器R1的装备:

R1(config)#interface e1/0 * 进入E1/0接口。

R1(config-if)#pppoe enable * 在该接口发动PPPOE协议。

R1(config-if)#pppoe-client dial-pool-number 1 * 将物理接口与虚拟拨号池1相关,这儿的编号1是拨号池编号,该编号有必要与拨号接口下的dialer pool 1中的池编号1相同。

R1(config-if)#no shutdown * 激活该接口。


R1(config)#interface dialer 1 * 树立一个拨号接口1

R1(config-if)#mtu 1492 * 装备拨号接口1的MTU为1492,为什么要装备为1492?

R1(config-if)#ip address negotiated * 装备该拨号接口通过DHCP取得IP地址。

R1(config-if)#dialer pool 1 * 将dialer1这个拨号接口与拨号地址池1相相关,这儿的拨号地址池dialer pool 1中的编号有必要与物理接口下dial-pool-number 1的编号相同。

R1(config-if)#encapsulation ppp * 为拨号接口封装PPP协议。

R1(config-if)#ppp authentication pap callin * 在拨号接口上运用PAP认证,并且只要求DSL的效劳器端验证客户端拨入行为,不要求拨号客户端验证效劳端。后有更详细的阐明。

R1(config-if)#ppp pap sent-username adsl02 password ccna456 *发送认证名与暗码。


为什么要将dialer 1拨号接口的MTU装备成为1492字节?

这与PPPOE规范中的MRU(最大接纳单元)有关,由于PPPOE的MRU所洽谈的巨细,必定不能超过1492个字节,PPPOE是被以太网所承载,以太网的MTU(最大传输单元)是1500个字节,其间PPPOE的头部要占6个字节,PPP协议ID要占2个字节,所以PPPOE的最大接纳单元便是1500-6-2=1492个字节。


关于PPPOE拨号客户端上的ppp authentication pap “callin”阐明:

对callin参数的了解必定要留意,很简单单让初学者通过“中国式英语”直接将关键字callin了解为“进入呼叫”,然后就会以为,电信运营商会恳求DSL客户端认证自已,甚至于从callin这个关键字,误以为电信运营商(DSL的效劳器)还要回拨客户端,然后在DSL客户端上有必要装备callin关键字,来答应DSL效劳器的呼叫进入,才干进行DSL网络的成功拨号,许多文档都这样描绘,如下图X所示

首要声明pppauthentication pap callin的正确了解:

在PPPOE拨号客户端路由器上装备callin关键字, 绝不是指回拨,或许对电信端(DSL效劳器)进行PAP认证,意思正好相反,它不要求认证效劳端,只对“拨入行为callin”(这儿的拨入行为指的是DSL客户端拨效劳器的行为)进行单向的认证,单项的认证指示:只让DSL网络的效劳器端认证客户端,而客户端不需求认证效劳端,并且会疏忽效劳端发来的认证恳求,或许叫客户端不要求效劳端供给认证恳求,假如在DSL的拨号客户端上装备ppp authentication pap不带callin参数,这才是要求对端(DSL效劳端)有必要供给认证主恳求,也便是客户端有必要去验证效劳端。关于这callin参数的详解原英阐明如下图Y所示,或许参看思科官方的关于

Configuring andTroubleshooting PPP Password Authentication Protocol (PAP)

文档ID为:Document ID: 10313

留意:在阅览时,不要将整句中的单词拆开来了解,这是在翻译英文文档时最简单呈现的问题,假如一但分折单词来了解,就很或许从一个独立单词的外表意思去先入为主的了解整个语句的中心思想,并且要留意关键词和专业术语的语态(是正在进行时或许被迫时),以及相关介词所引出的进一步阐明,通过这个提示,再仔细读读图Y的文档。


为什么callin参数不是电信运营商的DSL效劳端回拨客户端?

回拨(callback)不是callin,回拨的首要意图是为了给主叫方(英文叫calling,也便是拨号客户端)省费的一种计划,比方:说拨号客户端,首要初始化衔接效劳端,在通讯学记费的视点讲,应该向主叫方(caling)也便是拨号客户端收费,被叫方(called)也便是效劳端是不会发生费用的,这个道理就像打电话给钱,接电话不要钱的意思是相同,可是在有些企业里边,为了一致付费和节约拨号客户端的费用,效劳端会被装备为回拨(callback),此刻,状况会是这样:拨号客户端初始化衔接效劳端,效劳端收到初始化后,堵截衔接,然后由被叫方(called)也便是效劳端,反过来呼叫主叫方(calling),然后费用将发生在效劳端上,这个进程叫回拨,有点类似于曾经运用BB机,打传呼的进程。装备回拨的指令是callback,而不是callin。最终你再试想一个问题:你运用DSL的拨号,呼叫电信的接入效劳器,假如电信效劳器给你做回拨,那么就会变成,用户上网,电信给钱的“美丽作业”,谁都想,但或许吗?


当完结PPPOE的拨号路由器R1完结装备后,能够通过在路由器R1上履行show interface dialer 1 指令来检查拨号接口,如下图8.113所示,指示该路由器的拨号接口现已发动,并从PPPOE效劳端得到了IP地址。然后能够通过在路由器R1上测验与PPPOE效劳器的连通性,如下图8.114所示。

第四步:完结整个装备后,能够PPPOE的效劳端(DSL网络的会聚路由器)检查PPPOE拨号计算机与路由器一起拨入效劳端的状况信息,能够通过在DSL网络会聚路由器上履行show pppoe session指令来检查PPPOE的会话,如下图8.115所示,能够看到拨号计算机与拨号路由器成功的衔接到PPPOE的效劳器,其间,需求要点了解的是在给定的显现中,有两种ID,一个是PPPOE的PPPOE的主机仅有标识ID(Host-Uniq ID);一个是PPPOE的会话ID(SID),这两个ID有什么差异?为什么会存在这种标识PPPOE的ID?

PPPOE的主机仅有标识ID(Host-Uniq ID):

Host-Uniq ID,类似于PPP数据报文中的标识域,首要是用来辨认PPPOE的发送和接纳端的。由于关于播送式的网络中会一起存在许多个PPPoE的数据报文,说得更详细一点:比方:在PPPOE的发现阶段,某台主机发送一个PADI的PPPOE初始音讯,PPPOE的效劳端回送了一个PADO的PPPOE的供给音讯,那么就运用Host-Uniq ID来辨认,这一对音讯是一组PPPOE的操控会话,不然,正如上述关点:由于关于播送式的网络中会一起存在许多个PPPoE的数据报文,效劳端怎样知道哪个报文是详细某台主机发来的。事实上,从了解并取证PPPOE的作业进程中的四个发现阶段的操控音讯数据帧能够看出,每一个操控恳求与回送音讯的Host-Uniq ID是相同的。


PPPOE的会话ID(SID):

PPPOE的会话ID(SID)是通过在发现阶段的最终一步,所供给的会话ID号和对方的MAC地址一起来界说了一个PPPOE的会话,更准确的讲:是PPPOE发现阶段今后的会话ID,那些,关于PPP的LCP、NCP都是根据这个PPPOE的会话ID来标识是同一组会话音讯。


PPPOE的SID与Host-Uniq ID的差异在哪里?

由于PPPOE有必要要首要通过发现阶段(PADI、PADO、PADR、PADS)后才干进入正式的PPP会话阶段,正式的PPP会话阶段中,运用SID来标识同一PPP会话,可是在正式会话前的发现阶段,将运用Host-Uniq ID来标识发现阶段的一对PPPOE会话,由于此刻无法运用SID,它是发现阶段的第四步才被PPPOE的效劳端颁布,在发现阶段的前面几个进程中都不存在,所以此刻只能运用Host-Uniq ID来标识发现阶段的一对PPPOE会话。


版权声明
本文来源于网络,版权归原作者所有,其内容与观点不代表AG环亚娱乐立场。转载文章仅为传播更有价值的信息,如采编人员采编有误或者版权原因,请与我们联系,我们核实后立即修改或删除。

猜您喜欢的文章